VTP (VTP Pruning) : VTP 가지치기
EVE-NG 가상 에뮬레이터 실습
Switch 는 VLAN10 Access Port를 가지고 있고,
Switch2, Swithc3 은 VLAN 20 Access Port 를 가지고 있습니다.
위의 구성으로 볼 때
Switch 의 VLAN 10 프레임은 오른쪽으로 플러딩 될 필요가 없고
Swithc2, Swithc3 VLAN 20 프레임은 왼쪽으로 플러딩 될 필요가 없습니다.
플러딩 트래픽을 제한함으로써 대역폭의 낭비를 줄일 수 있습니다.
실습을 해보면서 동작을 살펴 보겠습니다.
!!!--- Switch ---!!!
conf t
!
vlan 10
name ##VLAN10##
vlan 20
name ##VLAN20##
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
!
vtp mode Server
vtp domain cisco
vtp password cisco
vtp version 2
!
end
!!!--- Switch2 ---!!!
conf t
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
switchport access vlan 20
switchport mode access
!
vtp mode client
vtp domain cisco
vtp password cisco
vtp version 2
!
end
!!!--- Switch3 ---!!!
conf t
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/1
switchport access vlan 20
switchport mode access
!
vtp mode client
vtp domain cisco
vtp password cisco
vtp version 2
!
end
VTP를 운영하기 위한 기본 설정을 마쳤습니다.
VTP 상태를 확인 해보겠습니다.
Switch#show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 5000.0009.8000
Configuration last modified by 0.0.0.0 at 1-18-21 14:16:29
Local updater ID is 0.0.0.0 (no valid interface found)
Feature VLAN:
--------------
VTP Operating Mode : Server
Maximum VLANs supported locally : 1005
Number of existing VLANs : 7
Configuration Revision : 2
MD5 digest : 0xFD 0xBE 0xB4 0x71 0x6A 0xDD 0xE4 0x36
0xBB 0x5E 0x91 0x5E 0xBA 0x05 0xBF 0xA4
Switch#show vlan br
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/2, Gi0/3, Gi1/0, Gi1/1
Gi1/2, Gi1/3
10 ##VLAN10## active Gi0/1
20 ##VLAN20## active
================================================================================
Switch2#show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 5000.0002.8000
Configuration last modified by 0.0.0.0 at 1-18-21 14:16:29
Feature VLAN:
--------------
VTP Operating Mode : Client
Maximum VLANs supported locally : 1005
Number of existing VLANs : 7
Configuration Revision : 2
MD5 digest : 0xFD 0xBE 0xB4 0x71 0x6A 0xDD 0xE4 0x36
0xBB 0x5E 0x91 0x5E 0xBA 0x05 0xBF 0xA4
Switch2#show vlan br
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/3, Gi1/0, Gi1/1, Gi1/2
Gi1/3
10 ##VLAN10## active
20 ##VLAN20## active Gi0/2
================================================================================
Switch3#show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 5000.0003.8000
Configuration last modified by 0.0.0.0 at 1-18-21 14:16:29
Feature VLAN:
--------------
VTP Operating Mode : Client
Maximum VLANs supported locally : 1005
Number of existing VLANs : 7
Configuration Revision : 2
MD5 digest : 0xFD 0xBE 0xB4 0x71 0x6A 0xDD 0xE4 0x36
0xBB 0x5E 0x91 0x5E 0xBA 0x05 0xBF 0xA4
Switch3#show vlan br
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/2, Gi0/3, Gi1/0, Gi1/1
Gi1/2, Gi1/3
10 ##VLAN10## active
20 ##VLAN20## active Gi0/1
이제 VTP Pruning 설정을 해보겠습니다.
Server 모드에서만 가능 합니다.
Switch(config)#vtp pruning
Pruning switched on
Switch(config)#
Server Mode 의 스위치에서 vtp pruing 설정을 해주면
같은 도메인에 있는 스위치들은 자동으로 VTP Pruing Mode 가 Enabled 됩니다.
확인해보겠습니다.
VTP Pruning Mode 가 Enabled 로 보입니다.
Switch#show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP Traps Generation : Disabled
Device ID : 5000.0009.8000
Configuration last modified by 0.0.0.0 at 1-18-21 14:22:16
Local updater ID is 0.0.0.0 (no valid interface found)
==============================================================
Switch2#show vtp devices
Device information can be only retrieved in VTP version 3
Switch2#show vtp sta
Switch2#show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP Traps Generation : Disabled
Device ID : 5000.0002.8000
Configuration last modified by 0.0.0.0 at 1-18-21 14:22:16
==============================================================
Switch3#show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP Traps Generation : Disabled
Device ID : 5000.0003.8000
Configuration last modified by 0.0.0.0 at 1-18-21 14:22:16
VTP Pruning 이 설정 되었기 때문에
Trunk Port를 통해 플러딩 되는 것을 차단하여 대역폭을 절약 할 수 있게 되었습니다.
감사합니다.
2021/01/17 - [Network] - VTP (VLAN Trunking Protocol) [②]
VTP (VLAN Trunking Protocol) [②]
VTP (VLAN Trunking Protocol) VTP 메세지는 어떤 정보를 담고 있고, 어떻게 주고 받을까요? 1. Summary advertisements 5분 주기로 전달하며, VLAN 정보에 변화가 생기면 5분이 되기전에 전달 합니다. Summary..
yolokhm.tistory.com
2021/01/16 - [Network] - VTP (VLAN Trunking Protocol) [①]
VTP (VLAN Trunking Protocol) [①]
VTP (VLAN Trunking Protocol) 작은 규모의 네트웍을 운영한다면 몇 대의 Switch 장비만을 설정 하면 됩니다. 그러나, 수십 수백개의 Switch를 운영 할 때 VLAN 추가,생성,삭제 설정을 하려면 각 장비에 접속하
yolokhm.tistory.com
'Network' 카테고리의 다른 글
VTP (VLAN Trunking Protocol) [②] (0) | 2021.01.17 |
---|---|
VTP (VLAN Trunking Protocol) [①] (0) | 2021.01.16 |
VLAN (SVI, Trunk mode) [③] (0) | 2021.01.16 |
VLAN (SVI) [②] (0) | 2021.01.16 |
VLAN (Access Mode, Access Vlan) [①] (0) | 2021.01.14 |